2

Closed

4.0 version - deployment error - Could not load file or assembly 'Microsoft.BizTalk.Scheduler, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

description

Hello.

I installed the version 4.0 of the adapter and I successfully used it, but after making some modifications in my orchestration I tried to redeploy the application and I get the following error:

Failed to add resource(s). Change requests failed for some resources. BizTalkAssemblyResourceManager failed to complete end type change request. Failed to update binding information. Could not validate TransportTypeData, Address or Public Address properties for Receive Location 'Receive Schedule Location'. Could not load file or assembly 'Microsoft.BizTalk.Scheduler, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

I checked the installed assemblies and the assembly Microsoft.Biztalk.Scheduler, version 3.0.1.0 is missing.

I tried to stop the application before deployment, but I am able to redeploy only if I delete the receive locations where I am currently using this transport type.
Closed Mar 4 at 6:29 PM by sandro_asp

comments

miguelcarvalho wrote Dec 11, 2012 at 9:20 AM

Hi,

unfortunately I also have the same problem with the missing assembly.
As a result the receive port with the schedule adapter naturally doesn't work.

Could someone please give feedback about this issue?

Thanks

miguelcarvalho wrote Dec 11, 2012 at 9:37 AM

Hi again,

I found the assembly. It is in your Biztalk install directory.
If it is correct that it is not installed in GAC by the adapter, I have no idea.

cristinagruescu wrote Dec 13, 2012 at 1:30 PM

Hello.

Thank you for specifying where I can find the dll file! After adding it to GAC, as expected, I could redeploy the application without deleting the receive location.

wrote Feb 14, 2013 at 7:13 PM

SimonClendon wrote Jul 2, 2013 at 3:30 AM

Thanks for the post. I used the following manual steps to resolve this issue:
  1. Open BizTalk administration console
  2. Right click on application "BizTalk Application 1"
  3. Select Add | BizTalk Assemblies
  4. Click the Add button
  5. Browse and select C:\Program Files (x86)\Microsoft BizTalk Server 2013\Microsoft.BizTalk.Scheduler.DLL
  6. Click Open
  7. Check on Overwrite all
  8. Check on:
    • “Add to the global assembly cache on add resource (gacutil)”
    • “Add to the global assembly cache on MSI import (gacutil)”
    • “Add to the global assembly cache on MSI file install (gacutil)”
  9. Click OK

wrote Mar 28, 2014 at 2:39 PM

wrote Mar 4 at 6:29 PM